Temporary Suspension of Royal Mail Services to Canada

Incident Report for ShippyPro

Resolved

Postal service to Canada has been restored, even if strike action is still ongoing
Posted Oct 21, 2025 - 15:23 CEST

Identified

Due to nationwide strike action by the Canadian Union of Postal Workers Royal Mail is suspending all outbound services to Canada. If you have recently sent items to Canada, we suggest checking directly with Royal Mail for the latest updates and service availability.
Posted Sep 30, 2025 - 09:26 CEST
This incident affected: Carriers (RoyalMail).