DHL Connect label creation temporarily unavailable

Incident Report for ShippyPro

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 10:46 CEST

Identified

The server of the carrier has an outage.
They are working to deploy a fix as soon as possible.
Posted Apr 24, 2026 - 08:39 CEST
This incident affected: Carriers (DHLConnect).