DPD Local delays in Aberdeen and Inverness

Incident Report for ShippyPro

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 10:48 CET

Monitoring

DPD Local is facing delays on deliveries and collections in the area of Aberdeen and Inverness due to poor weather conditions.
Posted Nov 20, 2025 - 19:11 CET
This incident affected: Carriers (DPDUK).