Shipments towards Canada may be suspended due to Industrial action
Incident Report for ShippyPro
Update
Due to industrial action by the Canadian Union of Postal Workers in Canada, Royal Mail and Deutsche Post suspended the shipments toward Canada. Considering the nature of the issue, also other carriers might be affected, resulting in delays and shipments in error.
Posted Dec 02, 2024 - 16:43 CET
Identified
Due to industrial action by the Canadian Union of Postal Workers in Canada, Royal Mail suspended the shipments toward Canada. Considering the nature of the issue, also other carriers might be affected, resulting in delays and shipments in error.
Posted Nov 28, 2024 - 08:57 CET
This incident affects: Carriers (DeutschePost, RoyalMail).