DHL Parcel potential disruptions

Incident Report for ShippyPro

Resolved

The carrier confirms the issue has been resolved on their end, so it is fully useable again.
Posted May 09, 2025 - 12:28 CEST

Identified

The carrier informed us of an issue on their end that might affect label creation - We will let you know as soon as they confirm a resolution.
Posted May 09, 2025 - 12:03 CEST
This incident affected: Carriers (DHLParcel).