DHLparcelUK shipments not working

Incident Report for ShippyPro

Resolved

This incident has been resolved.
Posted Apr 03, 2023 - 15:00 CEST

Monitoring

Carrier managed to solve the issue on their side, we are still monitoring the situation
Posted Apr 03, 2023 - 10:25 CEST

Investigating

We are in touch with the carrier.
They are working to solve the issue on their side
Posted Apr 03, 2023 - 10:18 CEST
This incident affected: Carriers (DHLParcelUK).