DeutschePost Ecommerce US tracking limited availability

Incident Report for ShippyPro

Resolved

The carrier confirmed that now Ecommerce US is up and running.
Posted Sep 03, 2026 - 11:27 CEST

Identified

The carrier informed us that "the tracking of Ecommerce US shipments is currently not possible and an error 5xx is being returned. the team is working with the highest urgency to resolve this as soon as possible. All other services will be available".

We will keep in touch with the carrier and inform you as soon as they solve this issue.
Posted Sep 03, 2026 - 10:10 CEST
This incident affected: Carriers (DeutschePost).