System emails not delivered

Incident Report for ShippyPro

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 13:48 CET

Monitoring

Our developers implemented a resolutive fix, we will keep the situation monitored.
Posted Nov 24, 2025 - 12:02 CET

Investigating

System emails coming from ShippyPro such as OTPs, password resets and email labels are not being delivered - Our developers are working to resolve the issue, we will keep you informed you as soon possible. Tracking emails are unaffected.
Posted Nov 24, 2025 - 09:48 CET
This incident affected: ShippyPro (ShippyPro Platform (UI)).