SDA shipments not working as expected
Incident Report for ShippyPro
Resolved
The incident with SDA has been resolved.
You should elaborate the order once again to complete the shipment.
Posted May 15, 2023 - 11:27 CEST
Identified
The issue has been identified and a fix is being implemented
Posted May 15, 2023 - 11:08 CEST
This incident affected: Carriers (SDA).