Sagawa label generation temporary unavailable

Incident Report for ShippyPro

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 09:20 CET

Monitoring

Labels are being generated without issues now - We will keep the situation monitored.
Posted Nov 25, 2025 - 14:15 CET

Identified

The carrier confirmed an issue on their end caused by high traffic volumes - We will update you as further feedback is shared on their end.
Posted Nov 25, 2025 - 09:18 CET

Investigating

Sagawa is experiencing some outages, your orders might be impacted - We have reached out to the carrier to investigate further, we will update you as soon as possible.
Posted Nov 24, 2025 - 09:55 CET
This incident affected: Carriers (Sagawa).