Seurv2: label creation temporarily unavailable

Incident Report for ShippyPro

Resolved

The carrier confirmed the deployment of a resolutive fix.
Posted May 27, 2025 - 16:56 CEST

Identified

The carrier confirmed an issue on their end, they're working to fix it as soon as possible - We will keep you updated as soon as we receive further feedback.
Posted May 26, 2025 - 12:45 CEST

Investigating

The service is experiencing some outages, your orders might be impacted.
Posted May 26, 2025 - 11:28 CEST
This incident affected: Carriers (Seurv2).