MondialRelay: label creation temporarily unavailable
Incident Report for ShippyPro
Resolved
This incident has been resolved.
Posted Nov 18, 2024 - 08:03 CET
Investigating
The service is experiencing some outages, your orders might be impacted.
Posted Nov 18, 2024 - 07:53 CET
This incident affected: Carriers (MondialRelay).