Failure to return TNT Italy rates

Incident Report for ShippyPro

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 11:43 CEST

Investigating

We are currently not receiving rates from TNT italy.
We are currently investigating the issue and we will give you new updates as soon as possible.
Posted Jun 26, 2025 - 11:36 CEST
This incident affected: Carriers (TNTItaly).