BRT shipments are not showing an updated tracking status

Incident Report for ShippyPro

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 14:04 CET

Monitoring

The orders now have the correct tracking status.
We will keep monitoring the updates
Posted Mar 12, 2026 - 14:00 CET

Identified

We are aware that BRT shipments' tracking statuses are not updated; they will be available in the next 2 hours
Posted Mar 12, 2026 - 09:35 CET
This incident affected: Carriers (BRT).