CTT: label creation temporarily unavailable

Incident Report for ShippyPro

Resolved

This incident has been resolved.
Posted May 08, 2025 - 12:08 CEST

Investigating

The service is experiencing some outages, your orders might be impacted.
Posted May 08, 2025 - 12:03 CEST
This incident affected: Carriers (CTT).