DHL Parcel return services disruption

Incident Report for ShippyPro

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 12:14 CET

Identified

DHL Parcel is facing disruptions on their return services, return shipments might be affected. The carrier is working on a fix.
Posted Nov 28, 2025 - 17:33 CET
This incident affected: Carriers (DHLParcel).