Platform slowdown

Incident Report for ShippyPro

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 13:09 CEST

Monitoring

The situation got back to normal, and we will keep monitoring the situation.
Posted Jun 16, 2026 - 12:38 CEST

Investigating

We are currently experiencing some slowdowns on the platform. Our team is already investigating the issue and working to restore normal performance as soon as possible. We apologize for any inconvenience caused.
Posted Jun 16, 2026 - 11:54 CEST
This incident affected: ShippyPro (ShippyPro Platform (UI)).